安卓低版本emoji导致APP白屏

其他环境
¥5.00

使用UNI-APP开发的混合app,里面有商城模块、社交模块、拼团模块等功能。打包后高版本的安卓手机可以正常进入和使用,手机的安卓版本低于4.4及以下时,app就进不去了,一直白屏。经排查是,是因为社交模块里面用到emoji表情导致的,程序到这里就无法继续记载了。有什么办法可以解决吗?多谢了

最佳答案

低版本安卓系统并不支持新版本的emoji表情,仅支持比较老的一些emoji表情。emoji表情的字符会导致加载app时无法识别,导致报错,就不能进入app了,于是出现白屏。可以筛选出低版本支持的emgi表情,可以通过接口的形式获取表情数据

郭郭 T0 被采纳率75%
2020-05-27 13:59
打赏 0 0
页面统计
425 访问
0 帮助
0.00 打赏

hierror 2019 © hierror.com 京ICP备13026190号-1

通知消息
  • 暂无任何消息